Tags:
create new tag
, view all tags

OpenFlow Testbed IP Address and Virtual LAN

This page contains the IP addressing scheme that is used on the Testbed.

IP Addresses

Network Network Addresses/Subnet Mask
Raspberry Pi's 192.168.0.0/16
OpenFlow Controller and Switches 10.0.0.0/24

Name IP Address
Server 192.168.0.1 and 10.0.0.1
Switch 1 10.0.0.10
Switch 2 10.0.0.20
Rack 1 192.168.1.1 to 192.168.1.8
Rack 2 192.168.2.1 to 192.168.2.8
Rack 3 192.168.3.1 to 192.168.3.8
Rack 4 192.168.4.1 to 192.168.4.8

network_hardware.png

Configuration

/etc/hosts (appended to Server and Raspberry Pi's)
# Used for OpenFlow
# Used to address server and openflow switches
192.168.0.1	server

# The following lines are used for identifying Raspberry Pi's
# Rack 1
192.168.1.1	pi1.1
192.168.1.2	pi1.2
192.168.1.3	pi1.3
192.168.1.4	pi1.4
192.168.1.5	pi1.5
192.168.1.6	pi1.6
192.168.1.7	pi1.7
192.168.1.8	pi1.8
# Rack 2
192.168.2.1	pi2.1
192.168.2.2	pi2.2
192.168.2.3	pi2.3
192.168.2.4	pi2.4
192.168.2.5	pi2.5
192.168.2.6	pi2.6
192.168.2.7	pi2.7
192.168.2.8	pi2.8
# Rack 3
192.168.3.1	pi3.1
192.168.3.2	pi3.2
192.168.3.3	pi3.3
192.168.3.4	pi3.4
192.168.3.5	pi3.5
192.168.3.6	pi3.6
192.168.3.7	pi3.7
192.168.3.8	pi3.8
# Rack 4
192.168.4.1	pi4.1
192.168.4.2	pi4.2
192.168.4.3	pi4.3
192.168.4.4	pi4.4
192.168.4.5	pi4.5
192.168.4.6	pi4.6
192.168.4.7	pi4.7
192.168.4.8	pi4.8

Virtual LANs (VLAN)

VLANs configuration is present on the Server and the Switches. The Server requires VLAN configuration for simultaneous communication with the Raspberry Pi's as well as to the Switches to act as an OpenFlow Controller. All OpenFlow instances on the Switches except for the Management VLAN (which should be run without OpenFlow) require a separate VLAN to operate on.

VLAN Configuration

Server

/etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 10.0.0.1 
netmask 255.255.255.0
network 10.0.0.0 
broadcast 10.0.0.255

auto eth0.100
iface eth0.100 inet static
address 192.168.0.1
netmask 255.255.0.0
network 192.168.0.0 
broadcast 192.168.255.255 
vlan-raw-device eth0

Switches

running configuration
; J9470A Configuration Editor; Created on release #K.15.10.0009
; Ver #03:03.1f.ef:f0
hostname "HP-3500-24"
module 1 type j94dda
ip default-gateway 10.0.0.1
snmp-server community "public" unrestricted
openflow
enable
controller-id 1 ip 10.0.0.1 controller-interface vlan 1
instance "openflow_test_100"
member vlan 100
controller-id 1
limit software-rate 10000
enable
exit
exit
vlan 1
name "DEFAULT_VLAN"
untagged 21-24
ip address 10.0.0.10 255.255.255.0
exit
vlan 100
name "openflow_100"
untagged 1-20
tagged 23
ip address 192.168.0.10 255.255.0.0
exit
management-vlan 1
Topic revision: r3 - 2013-07-18 - DanielWeldon
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback